Аналитика и комментарии

06 мая 2014

Electronic Signature and Legal Validity of Electronic Documents

The banking community is a unique experimenter implementing such complicated security services as authentication, electronic signature (ES) and encryption. For all inertness and pathological craving for strict compliance to legislation norms credit and financial organizations were among the first to introduce these services in early 1990s.

Here we should briefly recall that according to Art. 5 of 63-FZ the ES may be of three types: plain, enhanced and encrypted certified signature. Bank has the right to use all three types of signatures. At the time of this article, Minkomsvyaz accredited only 5 VC of 317 in credit and financial sphere: OJSC "Sberbank of Russia", OJSC "Share commercial Bank of Support to Commerce and Business", OJSC "Alfa-Bank", "First Specialized depository", OJSC Bank "Vozrozhdeniye".

Today leading banks use ES in several forms. ES is widely used in RBS systems for customer's will registration. The most often used are: enhanced signature (ES) and encrypted certified signature (ECS). ECS uses cryptographic protection of information (CPI) as a means of signature, certified to the requirements of the Rus­sian FSB. CPI is also used in interaction with the state governmental agencies and

foundations (FTS, FSS, HIF, FBS, PFR, Rosstat, SBRFM etc.) in securities trad­ing systems and e-commerce. According to Art. 4 63-FZ ECS makes ES equal to handwritten. However, according to expert opinion despite this FZ provision one ES is not enough to give an electronic document legal force.

In my opinion, it is necessary to cre­ate a common space of trust (CST) not to ES, but also to other protection services designed to ensure ES legal effect. As we all know the CST should be based on the regulatory and legal framework, institu­tional arrangements and have correspond­ing technical base.

From a technical point of view ES can obtain legal force only by means of aggregate applying of multiple trusted services (TS). Let us enumerate the minimal set of TS: infrastructure and trusted means of generation, application and validation of ECS;developed system of affixing trusted time marking, synchronized to each accredited to the VC in time of root VC; supported in the current state within specified time interval (in hours), the system registers of powers and authorities of ECS owners;TS of identification and authentication shall be strictly regulated for each VC.

An electronic signature is a unique security service that included all three TS: authentication of data source -confirmation of the authenticity of the source of the data obtained (ISO 7498-2); ensuring data integrity, that means that data has not been modified or destroyed in an unauthorized manner (ISO 7498-2); impossibility of authorship denying (ISO/IEC 13888-1).

Authentication in remote interac­tion is also DS consisting of three compo­nents: providing authenticity of the iden­tifier (ISO/IEC 10181-2);belonging of authenticator proving authenticity which to a particular subject (ISO/IEC 10181­2); authentication of parties - confirma­tion that the interaction side is the one it's claimed (ISO 7498-2).

Trusted time service jointly with the service timestamps (RFC 3161 "Time-Stamp Protocol (TSP)") form trusted service time for all VCs involved in the formation and check of certificate status.

Validation Service (RFC 2459) is included into certifying service for elec­tronic messages. Checking authenticity of data associated with the signed message or document, as well as of certificates of sig­nature keys may be carried out via Inter­net X.509 Public Key Infrastructure Data Validation and Certification Server Proto­cols (DVCS) with receipt signed by served (RFC 3029). On-line Certificate Status Pro­tocol - OCSP (RFC 2560) is also used to check the status of certificate. Validation of Public Key Certificates (VPKC) can be per­formed separately.

Verification service for validity check of powers and authority of subject at the time of signature. Is also confirmed by acceptance acknowledgment (acknowledgement signed by server).

The abovementioned services may become trusted is the appropriate infrastructural solutions shall be created and maintained. 

text by Alexey Sabanov, Deputy General Director of "Aladdin R.D."
Читайте NBJ в Telegram
Поделиться: